Customer phone support unavailable
Incident Report for Lyyti
Resolved
This incident has been resolved.
Posted Nov 12, 2019 - 12:55 EET
Identified
Due to an ongoing incident at Zendesk, our customer support is currently unable to receive phone calls. We are working with Zendesk to get this issue resolved.
Posted Nov 12, 2019 - 10:31 EET
This incident affected: Lyyti Support.