Swedish phone support is currently unavailable
Incident Report for Lyyti
Resolved
This incident has been resolved.
Posted Jun 09, 2021 - 18:03 EEST
Identified
Our Swedish phone support is currently unavailable, due to an ongoing incident at Zendesk. The issue has been identified and is currently being investigated.

In the meantime, you can still reach our Swedish customer support by chat and email.

Sorry for any inconvenience this may cause.
Posted Jun 09, 2021 - 14:03 EEST
This incident affected: Lyyti Support.