Data Processing Delays
Incident Report for Lyyti
Resolved
This incident has been resolved.
Posted Feb 01, 2023 - 13:22 EET
Investigating
Our data processing infrastructure is running on heavy load, we are monitoring the situation
Posted Feb 01, 2023 - 13:04 EET
This incident affected: Lyyti Portal and Lyyti registration.