Email deliverability issues to Microsoft 365 addresses

Incident Report for Lyyti

Resolved

The global Microsoft 365 issue has been resolved, and email delivery has returned to normal. Any delayed emails affected by the outage are currently being resent.
Posted Sep 04, 2026 - 16:27 EEST

Identified

Due to a global issue in Microsoft 365 environment, we are currently experiencing email deliverability issues towards Microsoft hosted email addresses. We are monitoring the situation.
Posted Sep 04, 2026 - 15:11 EEST
This incident affected: Messaging.