Mail delivery issue
Incident Report for Lyyti
Resolved
This incident has been resolved.
Posted Nov 18, 2021 - 21:23 EET
Identified
We've identified an issue with our mail service provider, which most likely causes mails to not getting sent normally. Our mail service provider is currently working on a fix to remediate the issue.
Posted Nov 18, 2021 - 19:55 EET
This incident affected: Messaging.